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The barcode reader replaces the need to manually type long numbers by reading the code (the lines) and transferring the lines

numbers which then appear in farmerswife

 

Download Free Barcode Font
First download the free 3of9 barcode font by copying the link below into your web browser:

 http://www.squaregear.net/fonts/free3of9.shtml

At the bottom of the window click on ‘Down

From the author Matthew Welch: ‘3 of 9 (sometimes called "code 39") [is] a widely used barcode standard that includes capital

symbols. […] Most kinds of barcode scanners will recognize 3 of 9 just fine. […]Two versions of 3 of 9 are included. The font called "Free 3 of 9" is the basic 3 

of 9 standard. It includes letters and these symbols: $ % + 

the ASCII characters.’ 

If you are running Mac OSX 10.5 (Leopard) you will need to 

 

Install Free Barcode Font
To use Barcodes in farmerswife please follow the

barcode reader connected or which will be used as a label generator.

On Windows 

On Windows, unpack the zip folder onto your desktop then copy and paste the files into the ‘Font’ folder which is usually 

from the Start Menu � Settings � Control Panel 

On Mac OS X 

Unpack the zip file onto your desktop. Then go to the Finder 

bottom of the ‘Font’ column. Select the fonts

 

Select the barcode font in your 
Once you have installed the barcode font 

farmerswife Client and click on the Set Up button.

 

To select the installed barcode font click on the selector bar below ‘Barcode Font:’ and select the ‘Free 3 of 9’ font from the drop 

down list. Click ‘OK’ to finish the operation. You’ve successfully installed the barcode font.
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The barcode reader replaces the need to manually type long numbers by reading the code (the lines) and transferring the lines

wife in the field where you’ve placed the cursor.  

Download Free Barcode Font 
First download the free 3of9 barcode font by copying the link below into your web browser: 

http://www.squaregear.net/fonts/free3of9.shtml 

Download Free 3 of 9’ and save the zip file on your desktop. 

From the author Matthew Welch: ‘3 of 9 (sometimes called "code 39") [is] a widely used barcode standard that includes capital

will recognize 3 of 9 just fine. […]Two versions of 3 of 9 are included. The font called "Free 3 of 9" is the basic 3 

of 9 standard. It includes letters and these symbols: $ % + - . and /. The font called "Free 3 of 9 Extended" covers the extended 3 of 9 

If you are running Mac OSX 10.5 (Leopard) you will need to install the extended version 3 of 9 standard

Install Free Barcode Font 
please follow the steps below on every computer with a farmerswife

be used as a label generator. 

On Windows, unpack the zip folder onto your desktop then copy and paste the files into the ‘Font’ folder which is usually 

Control Panel � Fonts. 

Unpack the zip file onto your desktop. Then go to the Finder � Services � Font Book. In the Font Book click on the plus sign at the 

bottom of the ‘Font’ column. Select the fonts from the ‘3 of 9’ folder you previously downloaded and unzipped to your desktop.

 

Select the barcode font in your farmerswife Client Application
 into your system, you have to select it in your farmerswife

Client and click on the Set Up button. 

 

click on the selector bar below ‘Barcode Font:’ and select the ‘Free 3 of 9’ font from the drop 

Click ‘OK’ to finish the operation. You’ve successfully installed the barcode font. 
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The barcode reader replaces the need to manually type long numbers by reading the code (the lines) and transferring the lines into 

From the author Matthew Welch: ‘3 of 9 (sometimes called "code 39") [is] a widely used barcode standard that includes capital letters, numbers, and several 

will recognize 3 of 9 just fine. […]Two versions of 3 of 9 are included. The font called "Free 3 of 9" is the basic 3 

. and /. The font called "Free 3 of 9 Extended" covers the extended 3 of 9 standard. It includes all 

3 of 9 standard. 

wife Client installation that has a 

On Windows, unpack the zip folder onto your desktop then copy and paste the files into the ‘Font’ folder which is usually accessible 

. In the Font Book click on the plus sign at the 

from the ‘3 of 9’ folder you previously downloaded and unzipped to your desktop. 

 

Client Application 
wife Client. Therefore run the 

 

click on the selector bar below ‘Barcode Font:’ and select the ‘Free 3 of 9’ font from the drop 
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Barcode Reader/Scanner 
By default, most barcode readers enter automatically a CR ("Carriage Return") suffix after each correct read. Therefore when 

looking for a barcode scanner it is important that the reader is set to NOT send the CR after each swipe, since farmerswife just 

expects number/characters. You have to confirm the input by manually pressing intro or return. At our farmerswife test installation 

we use the Metrologic MS9520 Voyager KB wedge; this is just one of many barcode scanners. It works for us, and many of our 

customers. 

Other Barcode Readers in use by our customer base: 

• CCD-800 Barcode-Scanner USB, ASIN: B001BH955C 

• Metrologic MK 9520 Voyager Barcode Scanner 

• USB Handscanner MK-1000 Barcode-Scanner, Modellnummer: MK-1000, ASIN: B00346EF8A 

 

Barcode Reader Check Up  
After the installation of the barcode font please follow the steps below to test the connection of the barcode reader and that the 

font is properly installed in your system. 

First check that a barcode reader is correctly connected to the machine you want to work with. Check also that you have the 

correct drivers (if any) and that it lights up for operation.  

To perform the test please print this page first, then open a blank text file (Wordpad, MS word, notepad, text editor) and test if you 

are able to read the following barcodes. Scan the codes and check if the numbers that appear in the text file match the numbers 

displayed next to the barcode. 

 

*135* *54321* 

This is: *135* 

And will result in WIFE as 135. 

This is: *54321* 

And will result in WIFE as 54321. 

*12345* *974324* 

This is: *12345* 

And will result in WIFE as 12345. 

This is: *974324* 

And will result in WIFE as 974324. 

 

If you are not able to read the codes then please check the configuration manual of your barcode reader, and check thoroughly 

that it was properly set up and the use of the CR suffix disabled. Check also with the manufacturer of the barcode reader if there is 

no seemingly known reason for non-operation of the hardware.  

After you’ve disabled the use of the CR suffix of the barcode reader please test that the barcode reader is setup correctly. Perform 

the test above again and after a few scans, you should see a continuous string of characters, e.g. 1351234554321974324  

If the test went successful, open a farmerswife Client and make sure that you are able to enter a code successfully, as described 

above. Simply click in a field in farmerswife where you want the result of the barcode to show and then swipe the barcode.  

To create a correct output for the 3 of 9 barcode font it is important to type an asterisk (*) before and after the number e.g. 

*153969*. The barcode reader will in return not include the asterisks in the output but just give the number 153969.  

From the author a ‘Special note to MS Word users: There is a default setting in Word that changes text surrounded by *'s into bold text. This setting 

must be disabled for these fonts to work, otherwise the * characters that are necessary for the barcode to scan properly will be lost and the 

thickness of the bars will be altered. I have a copy of Word '97. The setting might be found in a different place in other versions but this is how I 

disabled it. From the Tools menu open the AutoCorrect dialog box. On the AutoFormat tab uncheck the box for "*Bold* and _underline_"’.  

 

Barcode sounds in WIFE  
Please note that WIFE requires QuickTime installation on the computer where you want to play the barcode sound. 
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Object Tracking: Configuration / Pre
• In Server Setup > Objects tab, configure the following options, as required:

o Object Tracker Barcode: Remove Leading “0”

o Object Tracker Barcode: Remove Chars. From End

o Use Tracker On Objects Without Inventory Number

inventory number. On these Objects it is not possible to 

number (inventory nr) to swipe against.

check out remaining Objects in the selection 

checked out of the facility or not

o Use Tracker On External Objects: 

allowing you to check them in/out as well.

• Inventory Number: to use the tracking option, it is necessary to enter inventory

number must be unique. This allows

 

• Toolbox / Settings / Display: select 

number, in the Object Tree and in the Bookings where they are added when displayed in the Project Tree.

 

• Toolbox / Settings / Display: select 

inventory number. 

• Toolbox / Objects: click on arrow at the top 

for information 
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Configuration / Pre-Requisites 
In Server Setup > Objects tab, configure the following options, as required: 

r Barcode: Remove Leading “0”: Enable it if leading “0” is to be removed.

Object Tracker Barcode: Remove Chars. From End: Enable it if characters from the end are to be removed.

Use Tracker On Objects Without Inventory Number: To use the Check In/Out for O

number. On these Objects it is not possible to use the Barcode Collector because 

nr) to swipe against. But when swiping other Objects with inventory

bjects in the selection can be used. The tracker will then show 

checked out of the facility or not. 

Use Tracker On External Objects: To enable the tracker on external objects (coming from external

u to check them in/out as well. 

tracking option, it is necessary to enter inventory number for each O

number must be unique. This allows swiping the barcode when colleting Objects to check out/in.

 

 

select Tracker: it will display an arrow icon (Tracker) next to each O

number, in the Object Tree and in the Bookings where they are added when displayed in the Project Tree.

 

select Inventory /Full Name: it will display the inventory number next to each 

click on arrow at the top and select Display / Tracker and Inventory/Full Name
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Enable it if leading “0” is to be removed. 

Enable it if characters from the end are to be removed. 

To use the Check In/Out for Objects that do not have an 

ollector because there is no barcode 

entory nrs., then the option to 

will then show if the Object has been 

enable the tracker on external objects (coming from external suppliers) 

number for each Object to be tracked. This 

bjects to check out/in.  

Tracker) next to each Object that has an inventory 

number, in the Object Tree and in the Bookings where they are added when displayed in the Project Tree. 

 

inventory number next to each Object that has an 

Inventory/Full Name: to show these columns 
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Checking Objects Out 
• Prepare a Booking and add some pieces of equipment

• Open the Booking, click on the Reports icon 

will take to the warehouse to request the equipment.

• The warehouse person will collect all the requested equipment as detailed in this report. Once ready, he will open 

farmerswife and go to Toolbox > Project tab 

starting to check out the equipment. This action will open the dialog 

equipment: 

 

• The equipment will get listed under the Object tab in the Toolbox

• A dialog asks to Modify Booking Times With Chec

booking start time to the check-out time.

• A window opens with three areas: 
1. Object That Will Not Be In The Booking

Objects from any of the other two areas to this one, simply click on them.

2. New Objects Added To The Booking

under this area. It may happen that a 

another. 

3. Objects In The Booking, But Not In Your Selection

listed under this area.  
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Prepare a Booking and add some pieces of equipment. 

Reports icon and select HTML Report > Warehouse copy without *. 

will take to the warehouse to request the equipment. 

The warehouse person will collect all the requested equipment as detailed in this report. Once ready, he will open 

Project tab and will scan the farmerswife Booking ID from the Warehouse report before 

he equipment. This action will open the dialog Sweep Barcode to start swiping the barcodes from the 

 

listed under the Object tab in the Toolbox. Once finished, press Done. 

Modify Booking Times With Check Out Time?: select No to keep booking start time

out time. 
 

Object That Will Not Be In The Booking: any objects that are moved to this area will be removed from the B

Objects from any of the other two areas to this one, simply click on them. 

New Objects Added To The Booking: if equipment that was not initially listed in the Booking is swiped, it will appear listed 

this area. It may happen that a specific requested equipment is not in the warehouse 

Objects In The Booking, But Not In Your Selection: if a specific equipment in the Booking has not been swiped, it will appear 
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Warehouse copy without *. This is the report the user 

The warehouse person will collect all the requested equipment as detailed in this report. Once ready, he will open 

from the Warehouse report before 

to start swiping the barcodes from the 

 

keep booking start time, or select Yes to modify 

oved from the Booking. To move 

ooking is swiped, it will appear listed 

equipment is not in the warehouse and so it is replaced with 

has not been swiped, it will appear 
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• Once done, hit OK. A dialog asking to 

that have not been swiped. Select 

• The Tracker arrow next to each Object in the Project Tree or in the Object Tree will

it will turn grey when it is checked in again.

• The Tracker arrow will appear red

specific Booking. 

 

 

Checking Objects In 
To check in an object, the same operation is repeated.

 

Object Tracker Window
The Object Tracker can be opened by double clicking on the Tracker arrow 

clicking on the Object either in the Toolbox

button. 

The Object Tracker displays a Tag with information of the project and booking, as

who checked it out/in and the date and time.

This window can also be used to check in or out the Object.
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. A dialog asking to Check Out The Remaining Objects (x)? will pop up if there are

Yes to check them out. 

Tracker arrow next to each Object in the Project Tree or in the Object Tree will turn green to show it is checked out and 

t will turn grey when it is checked in again. 

red next to an Object in a Booking to indicate that it is checked

 

in an object, the same operation is repeated. 

 
by double clicking on the Tracker arrow next to the Object in the Object tree,

bject either in the Toolbox > Objects tab, in the Object Tree or in the Hourline and then by c

The Object Tracker displays a Tag with information of the project and booking, as well as the Out and In with info about the 

date and time. 

This window can also be used to check in or out the Object. 
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if there are objects in that Booking 

reen to show it is checked out and 

checked-out, but not against that 

bject in the Object tree, or by double 

n the Object Tree or in the Hourline and then by clicking on the Tracker 

well as the Out and In with info about the user 
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Barcode Collector 
Access from Toolbox > Objects > Menu > Barcode Collector. 

It can be used to collect a list of equipment by scanning their barcodes to either checking them in or out. If there is a list of Objects 

in the Object tab, a dialog will ask to first clear this list. 

• Mark all Objects in the list, click on the drop-down arrow and select Tracker > Auto Check In Out. 

• Mark a Booking to be able to check in/out the Objects and select the second option to Add to Selected Booking If Not 

Already Added. 

 

 

 

 


